imagelogin

Author Topic: Communication Problem  (Read 1866 times)

0 Members and 1 Guest are viewing this topic.

rmauro

Communication Problem
« on: August 12, 2013, 12:26:56 AM »
Help!  I can't communicate with my Wiring board. 

I'm new to Wiring.

I've been trying to run the "Blink" program as a test.  I've set the serial port and the board to "Wiring V 1.0/Wiring Mini V 1.0 @ 16 MHz."  I've also tried a variety of variations with and without reseting the board.  I've tried it with both a PC and a Mac.

The board has a ATMEGA 128 processor (16 AU0641).  I consistently get the following messages:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer

Any suggestions?

Thanks,

Robert

bhagman

Re: Communication Problem
« Reply #1 on: August 18, 2013, 08:44:53 AM »
This sounds like the bootloader on the board that you're using is an old one.

You should try updating it to the latest one for the board you have.

Let me know if you need help doing that.

rmauro

Re: Communication Problem
« Reply #2 on: August 25, 2013, 12:35:57 AM »
Brett:

Thanks.  Yes I could use some help.  After reading your post I searched under "bootloader."  It appears that I need another board (which I don't have). Is that the case?  Can you point me in the right direction?

Thanks,

Robert