login

Author Topic: I'm having error uploading program on ATmega128.  (Read 3219 times)

0 Members and 1 Guest are viewing this topic.

sool3693

I'm having error uploading program on ATmega128.
« on: October 01, 2011, 08:25:10 AM »
Hello!

I have some errors during the process for using another board for Wiring IDE.

I flashed the bootloader for Wiring-Mini to my handmade ATmega128 board.

and I attached ft232 module TX pin to 128 pin 32(PD7), RX pin to 128 pin 33(PG0).

But, when I compile the code and clicked the upload button at wiring IDE, I have some errors like these.

--------------------------------------------------------------------
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
--------------------------------------------------------------------

I'm using Windows 7 - 64bit OS.

And I installed driver for FTDI devices.

And, I checked fuse bits.(I think there's no matter on fuses..)

It seems like bootloader in ATmega128 doesn't respond to IDE.

The only different thing between Wiring-Mini & My Board is Crystal.

Of course I'm using 16MHz crystal for main clock.

But, I didn't attached 32.768KHz crystal between TOSC pins.

Is it essential for programming?

I hope I can solve this..

Anyone can help with this problem..?



« Last Edit: October 01, 2011, 02:51:30 PM by sool3693 »

barragan

Re: I'm having error uploading program on ATmega128.
« Reply #1 on: October 02, 2011, 05:57:19 PM »
hi, which board are you using? have you burned a boot loader into it?

bhagman

Re: I'm having error uploading program on ATmega128.
« Reply #2 on: October 13, 2011, 05:18:02 PM »
Yeah, it sounds to me like you're missing the bootloader.

You'll need to burn the bootloader onto your ATmega128 first.

You can use Atmel's AVRStudio and an AVRISP or similar, or you can use a Wiring S board with the WiringISP sketch installed, and burn the bootloader from the Wiring IDE.

b