All Forums > Wiring Hardware Questions

Unable to load sketch to Wiring V1.0

(1/2) > >>

OK, this topic is not new--people have been wrestling with this for years. But still, I haven't seen a solution anywhere.

My Wiring board doesn't have a lot of labelling on it that helps to identify it, so I've attached a screen-shot.

When I plug the board into my computer, the green power LED comes on, and LED0 flashes orange. I try to load the 'Blink' demo.

Using the OOTB install of Wiring v1.0.1-dev, the process times out. When I substitute a more complete version of the 'boards.txt' file, I get 'avrdude: stk500_getsync(): not in sync: resp=0x55' (see other attached screen-shot).

The board is connecting to COM6, which is set to 115200 bps; the driver is FTDI. The selected board is 'Wiring 1.0 @ 16 MHz (STK500)'.

I have tried different cables and different USB ports.

I'd be very grateful for any help.

Jim McDonald

hi It is a very old board, the boot loader needs update, so you need another board to burn the boot loader into this one, and the Wiring IDE to do it, here some guides:


I've seen this 'solution' before.

I don't really get it. The suggestion is that I need to buy a new board as a source for the boot-loader code. If I can load code into my current board from another board, why can't I load it from my computer?

Or, if my old board isn't compatible with the current version of the Wiring development software, why can't I use a version that worked with it when it was new?

To me, this solution is no solution. I don't need or want two boards. I only want one, and I want it to work. So it seems to me that I might just as well throw my old board in the garbage, buy a new one, and use that.

But that's not very satisfactory. My old board didn't break. It isn't defective. All that happened to it is that the Wiring community made it obsolete, and now I have to buy a new one. If that's the case, it leaves me wondering if I want to be involved with this platform at all.

Is this really the only solution?


The boot loader in the board you have is about 10 years old, as you can imagine any things have changed since, in order to make the board usable the boot loader inside it needs to be replaced, it could be done with any newer board (not only Wiring boards) you could also use an Arduino compatible board (since wiring can program arduinos as well) to do it, perhaps it might be useful to ask a friend to lend you a board, it will take a few minutes to burn it. Once is burned you can use your board with the latest Wiring version.
In general the boot loader could be programmed using any of the boars in the Tools -> Boards menu.


Give  me your adress in a PM.

I can sent you a board you can use: for free (wiring service)


[0] Message Index

[#] Next page

Go to full version