Author Topic: Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit  (Read 1684 times)

0 Members and 1 Guest are viewing this topic.

athos

Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« on: November 23, 2015, 07:51:20 PM »
I have the same issue described at this topic:
http://forum.wiring.co/index.php/topic,92.0.html

but on a different ubuntu version. I replaced the java version in wiring directory with the oracle one:
mv java java_orig
ln -s /usr/lib/jvm/jdk1.8.0_60/ java

Wiring's sketchbook directory selection appears, but then I get this:
Code: [Select]
java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1122)
at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
at processing.app.Editor.populateSerialMenu(Editor.java:872)
at processing.app.Editor.buildToolsMenu(Editor.java:612)
at processing.app.Editor.buildMenuBar(Editor.java:489)
at processing.app.Editor.<init>(Editor.java:202)
at processing.app.Base.handleOpen(Base.java:986)
at processing.app.Base.handleOpen(Base.java:952)
at processing.app.Base.handleNew(Base.java:821)
at processing.app.Base.<init>(Base.java:289)
at processing.app.Base.createAndShowGUI(Base.java:169)
at processing.app.Base.access$000(Base.java:44)
at processing.app.Base$1.run(Base.java:116)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Any hint on how to solve this? Thanks!

athos

Re: Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« Reply #1 on: November 24, 2015, 07:32:38 PM »
Ok, I got this to work, somehow. Instead of linking to the oracle jvm, i linked to the openjdk one:
Code: [Select]
ln -s /usr/lib/jvm/java-1.7.0-openjdk-amd64 java

Now I get a popup window with a "Processing requires Java 6 from sun..." message, but then the IDE starts and everything seems to work. In the console I get this warning:

Code: [Select]
Stable Library
=========================================
Native lib Version = RXTX-2.2pre2
Java lib Version   = RXTX-2.1-7
WARNING:  RXTX Version mismatch
Jar version = RXTX-2.1-7
native lib Version = RXTX-2.2pre2

I also tested this on Ubuntu 15.04, with the same same errors and same fix.

barragan

Re: Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« Reply #2 on: December 01, 2015, 08:22:54 PM »
hi Athos, we need to produce release 101 for Linux, but I don´t have a Linux machine, can you make it from the github repo?