Author Topic: Installing Wiring in Linux  (Read 12428 times)

0 Members and 1 Guest are viewing this topic.


Installing Wiring in Linux
« on: March 24, 2012, 10:49:38 PM »
I have successfully installed and used the wiring software on my netbook (running Lubuntu 11.04)

Everything went perfectly, I unzipped the files into a folder (/home/kyle/wiring), double clicked the "wiring" script, it asked me if i wanted to display or execute, I chose execute, and it launched without issue, auto detected my Wiring S board, and let me get straight to work without issue.

I wanted to try it out on my desktop, (running ubuntu 11.10) but I've run into a problem.

I copied the same .tar.gz folder to the same directory (/home/kyle/wiring) and clicking the same "wiring" file, was asked the same question about if I wanted to display or execute, I chose execute, and it does absolutely nothing.  It just wont open or run on my desktop.

Any ideas?


Re: Installing Wiring in Linux
« Reply #1 on: March 24, 2012, 11:54:24 PM »
Hey Kyle,

Glad you made it to my class on Thursday!

Yeah, I saw that same problem on Ubuntu 11.10 desktop...

I am, by far, not an expert in Linux - as such I only know enough to be dangerous.

It would be interesting to hear from someone who is a Linux guru that can figure out that problem.

In the meantime, I suggest you do what I did...


You have to create a "Desktop Launcher" for Wiring - follow those instructions, and select the "wiring" script as the command.


Re: Installing Wiring in Linux
« Reply #2 on: March 25, 2012, 01:56:09 AM »
Hello Brett.

Thanks for leading such a wonderful class.

I tried creating a launcher, with "/home/kyle/wiring/wiring" as the command.  Sadly, no luck.  The computer makes the "I'm thinking real hard" sound for a second, then stops.

I'm wondering if this has anything to do with Ubuntu dropping sun Java and going with OpenJDK?  According to what I've found on Google, this is a likely cause, but I've now installed SunJava and I'm still having no luck.  I'm looking forward to finding a Linux guru who can hopefully sort this out.

In the meantime, I booted in Windows 7 and installed that version, which works fine.


Re: Installing Wiring in Linux
« Reply #3 on: March 25, 2012, 02:33:19 PM »
Tried using the terminal:

~$ /home/kyle/wiring/wiring
~$ Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/kyle/wiring/java/lib/i386/xawt/libmawt.so: libXext.so.6: cannot open shared object file: No such file or directory
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1699)
   at java.lang.Runtime.load0(Runtime.java:770)
   at java.lang.System.load(System.java:1003)
   at java.lang.ClassLoader$NativeLibrary.load(Native Method)
   at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1803)
   at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1720)
   at java.lang.Runtime.loadLibrary0(Runtime.java:823)
   at java.lang.System.loadLibrary(System.java:1028)
   at sun.security.action.LoadLibraryAction.run(LoadLibraryAction.java:50)
   at java.security.AccessController.doPrivileged(Native Method)
   at java.awt.Toolkit.loadLibraries(Toolkit.java:1605)
   at java.awt.Toolkit.<clinit>(Toolkit.java:1627)
   at processing.app.Base.<clinit>(Base.java:427)
Could not find the main class: processing.app.Base.  Program will exit.

Don't know if this helps point out the problem or not, but if I figure out a solution, it will be posted here for any other ubuntu users.


Re: Installing Wiring in Linux
« Reply #4 on: March 27, 2012, 10:29:23 PM »
I've been doing some more research into this issue.

Apparently, this same problem is very common with "processing", as well as wiring. 

According to various message boards, The issue seems to be that ubuntu 11.04 defaults to 32-bit java on a 64-bit system, and this leads to problems.

To test out this idea, I installed processing, and low and behold, I had the exact same issue with it failing to launch in Ubuntu 11.10

So I opened up the terminal and navigated over to my processing directory, and typed this:

rm -Rf java
ln -sfn /opt/jdk1.6.0_29 java

And processing now works perfectly!

So I navigated over to my Wiring directory and typed in the same thing into the terminal.

Now whenever I click on the "Wiring" script, I get a message asking me where it wants to save my sketches to, (Just like the first time using processing).  After selecting a location, nothing happens.  Wiring still wont load.

I do think I'm moving in a direction on this, (not sure if it's the right one or not...), but I will figure this out, even if I have to read a manual!


  • Newbie
  • *
  • Posts: 1
  • Why did they put so much smoke in my chip???
Re: Installing Wiring in Linux
« Reply #5 on: May 19, 2012, 06:19:09 PM »
This is my first time to post so if I'm in the wrong place to do this.. please don,t hit me I won,t do it again!
I have installed both Arduino and Wiring on the same box aad they both work super in Arduino. They are ignored by Wiring because they are not sensed as tyACM*, only as ttys*. I,ve moved the board defs from the Arduino IDE into the Wiring direrctory <peter>/Wirig/wiring-0100/hardware/Arduino  It did not change anything. Is there a known way to have the board recognized properly? It's alll very intriging as to why and kinda fun to figure out, but I'm looking forward to working with the Wring configuration. and spend time playing with it.. not working at it.
Any and all ideas are welcome. if my info is not clear enough be kind and ask me to fill in the blank spots .
It would be my pleasure.


Re: Installing Wiring in Linux
« Reply #6 on: December 21, 2017, 11:47:00 AM »
i'm sorry for replying to an old thread but I am having problems installing wiring on Linux and I was wondering if someone can help me, thanks, wanna do it now that i sit home doing nothng but searching for meds reviews. any help would be appreciated!
« Last Edit: January 31, 2018, 12:51:21 PM by Sibiler »