Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - Lemings

Pages: [1]
1
Wiring Hardware Questions / Re: Bootloader for custom board
« on: November 02, 2011, 04:34:28 PM »
Thanks for Your reply

See board datasheet in this link: http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=2&ved=0CCUQFjAB&url=http%3A%2F%2Fread.pudn.com%2Fdownloads130%2Fdoc%2F555562%2Fmega128_dev.pdf&ei=PaexTvGOO4bZ4QTo7LmqAQ&usg=AFQjCNGrJoLHR7G4Simq4KAhqgBAHg_dHw&sig2=pXx2ylnkR9-Xkf9sEBSF-A

I used bootloader shipped with wiring.

Created new mk file in hardware/Wiring/bootloader/build folder.

Created board definition in hardware/Wiring/bootloader/boards

Built by running make my-target in hardware/Wiring/bootloader/build folder.

After I put serial test program on my board (with the help of avr isp mkII) to I see that usart is working properly. And it did.

I assume something is wrong in bootloader built process, but I see LED flashing so bootloader is being executed.

I even tried using bdmicro bootloader but it is not working.
2
Wiring Hardware Questions / Bootloader for custom board
« on: November 02, 2011, 03:14:08 PM »
Hello!

At first I would like to say some kind words to creators of wiring IDE and libraries, You are great!

Now I want to move to wiring 1.0, before I used wiring 27 on same board.

I have a trouble creating bootloader for my custom board with 14.7456 MHz crystal. I created board entry, compiled bootloader. With the help of avrisp mkII flashed my board.

When I try to upload sketch from Wiring IDE avrdude can not connect to my board.

I have checked fuses, led on my board is flashing after reboot, so I believe bootloader is being executed.

I assume something is wrong with bootloader code, so any help is welcome!

Thanks in advance!
Pages: [1]