imagelogin

Recent Posts

Pages: 1 2 [3] 4 5 ... 10
21
Wiring Hardware Questions / One of the first wiring boards
« Last post by yakkov3353 on June 02, 2016, 01:27:52 PM »
Hi
Can anybody help with schematic and driver for a wiring board with no version number .
Do anybody has the right driver for the USB to serial  chip FT232BM

Thanks
22
Wiring News / Is Wiring Back?
« Last post by rei_vilo on May 25, 2016, 06:24:42 AM »
According to Sneak peek: Arduino’s Primo and Primo Core IoT duo, Arduino.ORG is working again with Hernando Barragán, the initiator of the Wiring framework, on which Arduino and Energia are based.

Quote
“Developing the Arduino IDE for the Primo and Primo Core is our main focus right now,” continues Giori. “In other words, the ‘Hello World’ of Arduino is to blink an LED (blinky sketch) and if you download that same sketch that runs on an Uno to your Primo, it will ‘just work’. The big effort for Arduino software developers is that this board does so much more than an Uno. The number of libraries and APIs has to therefore grow accordingly. Our software developers coordinate with Hernando Barragan, the author of Wiring which became the Arduino IDE, so our goal of course is to maintain the ease-of-use principle as we expand the core libraries."

Nice to see Wiring back! Should we expect Wiring++?
23
Wiring Implementations / Wiring port for the Raspberry Pi
« Last post by barakasMuh on May 12, 2016, 05:50:32 PM »
Thanks for all the good advice.

We are planning on doing the wiring on Sunday. Would appreciate it if someone might be able to post some pics before then. 

Who has experience hooking the extra wire to the auxiliary lights with the blade clips?  Do you know a better way?
24
Programming Questions / Checking if button was held in click handler
« Last post by barakasMuh on May 07, 2016, 10:59:43 AM »
well its just a list of commands, no logic or anything so theres not really anything anyone could suggest
25
Contributed Library Questions / MenuBackend
« Last post by Barbarian on March 23, 2016, 03:21:42 PM »
Hi! I'm new here.
I would like to ask something about MenuBackend library.
Is it possible after any interaction with the user to getting back on the screen the whole path of the item? Something like: Root\hardware\tools\item1 I think that would be very useful for navigation in more complex menus.
If it is possible, please tell me how to do it.
Thank you in advance!
26
In hardware/Atmel, edit the boards.txt file,
27
OK, decided to re-install Wiring with edited boards.txt and it did the trick.

Bhagman thank you! This phenq at https://skinnyexpress.com/phenq-review has helped me big time!!!!

Where is the edited boards.txt?
28
Installation Questions / Re: Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« Last post by barragan on December 01, 2015, 08:22:54 PM »
hi Athos, we need to produce release 101 for Linux, but I don´t have a Linux machine, can you make it from the github repo?
29
Installation Questions / Re: Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« Last post by athos on November 24, 2015, 07:32:38 PM »
Ok, I got this to work, somehow. Instead of linking to the oracle jvm, i linked to the openjdk one:
Code: [Select]
ln -s /usr/lib/jvm/java-1.7.0-openjdk-amd64 java

Now I get a popup window with a "Processing requires Java 6 from sun..." message, but then the IDE starts and everything seems to work. In the console I get this warning:

Code: [Select]
Stable Library
=========================================
Native lib Version = RXTX-2.2pre2
Java lib Version   = RXTX-2.1-7
WARNING:  RXTX Version mismatch
Jar version = RXTX-2.1-7
native lib Version = RXTX-2.2pre2

I also tested this on Ubuntu 15.04, with the same same errors and same fix.
30
Installation Questions / Wiring IDE 0100 won't start on Ubuntu 14.04 64 bit
« Last post by athos on November 23, 2015, 07:51:20 PM »
I have the same issue described at this topic:
http://forum.wiring.co/index.php/topic,92.0.html

but on a different ubuntu version. I replaced the java version in wiring directory with the oracle one:
mv java java_orig
ln -s /usr/lib/jvm/jdk1.8.0_60/ java

Wiring's sketchbook directory selection appears, but then I get this:
Code: [Select]
java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path thrown while loading gnu.io.RXTXCommDriver
Exception in thread "AWT-EventQueue-0" java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path
at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1864)
at java.lang.Runtime.loadLibrary0(Runtime.java:870)
at java.lang.System.loadLibrary(System.java:1122)
at gnu.io.CommPortIdentifier.<clinit>(CommPortIdentifier.java:83)
at processing.app.Editor.populateSerialMenu(Editor.java:872)
at processing.app.Editor.buildToolsMenu(Editor.java:612)
at processing.app.Editor.buildMenuBar(Editor.java:489)
at processing.app.Editor.<init>(Editor.java:202)
at processing.app.Base.handleOpen(Base.java:986)
at processing.app.Base.handleOpen(Base.java:952)
at processing.app.Base.handleNew(Base.java:821)
at processing.app.Base.<init>(Base.java:289)
at processing.app.Base.createAndShowGUI(Base.java:169)
at processing.app.Base.access$000(Base.java:44)
at processing.app.Base$1.run(Base.java:116)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:311)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:756)
at java.awt.EventQueue.access$500(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:709)
at java.awt.EventQueue$3.run(EventQueue.java:703)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$JavaSecurityAccessImpl.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:726)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82)

Any hint on how to solve this? Thanks!
Pages: 1 2 [3] 4 5 ... 10